microbik.ru
1

ГИА 9 класс

А8. Исполнение алгоритма для конкретного исполнителя.


  1. Исполнитель Черепашка перемещается на экране компьютера, оставляя след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существуют две команды:

Вперед n (где n – целое число), вызывающая передвижение Черепашки на n шагов в направлении движения.

Направо m (где m – целое число), вызывающая изменение направления движения на m градусов по часовой стрелке.

Запись ^ Повтори k [Команда1 Команда2 Команда3] означает, что последовательность команд в скобках повторится k раз.

Черепашке был дан для исполнения следующий алгоритм:

^ Повтори 10 [Направо 36 Вперед 20 Направо 36]

Какая фигура появится на экране?

1) Правильный пятиугольник

2) Правильный шестиугольник

3) Правильный десятиугольник

4) Незамкнутая ломаная линия


  1. Исполнитель Черепашка перемещается на экране компьютера, оставляя след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существуют две команды:

Вперед n (где n - целое число), вызывающая передвижение Черепашки на n шагов в направлении движения.

Направо m (где m – целое число), вызывающая изменение направления движения на m градусов по часовой стрелке.

Запись ^ Повтори 5 [Команда1 Команда2] означает, что последовательность команд в скобках повторится 5 раз.

Черепашке был дан для исполнения следующий алгоритм:

^ Повтори 6 [Вперед 10 Направо 72]

Какая фигура появится на экране?

1) незамкнутая ломаная линия

2) квадрат

3) правильный пятиугольник

4) правильный шестиугольник


  1. Исполнитель Черепашка перемещается на экране компьютера, оставляя след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существуют две команды:

Вперед n (где n – целое число), вызывающая передвижение Черепашки на n шагов в направлении движения.

Направо m (где m – целое число), вызывающая изменение направления движения на m градусов по часовой стрелке.

Запись ^ Повтори k [Команда1 Команда2 Команда3] означает, что последовательность команд в скобках повторится k раз.

Черепашке был дан для исполнения следующий алгоритм:

^ Повтори 12 [Направо 45 Вперед 20 Направо 45]

Какая фигура появится на экране?

1) квадрат

2) правильный двенадцатиугольник

3) правильный восьмиугольник

4) незамкнутая ломаная линия


  1. Исполнитель Черепашка перемещается на экране компьютера, оставляя след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существуют две команды:

Вперед n (где n – целое число), вызывающая передвижение Черепашки на n шагов в направлении движения.

Направо m (где m – целое число), вызывающая изменение направления движения на m градусов по часовой стрелке.

Запись ^ Повтори k [Команда1 Команда2 Команда3] означает, что последовательность команд в скобках повторится k раз.

Черепашке был дан для исполнения следующий алгоритм:

^ Повтори 4 [Направо 60 Вперед 20 Направо 60]

Какая фигура появится на экране?

1) правильный треугольник

2) квадрат

3) правильный шестиугольник

4) незамкнутая ломаная линия


  1. Исполнитель Черепашка перемещается на экране компьютера, оставляя след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существуют две команды:

Вперед n (где n – целое число), вызывающая передвижение Черепашки на n шагов в направлении движения.

Направо m (где m – целое число), вызывающая изменение направления движения на m градусов по часовой стрелке.

Запись ^ Повтори k [Команда1 Команда2] означает, что последовательность команд в скобках повторится k раз.

Черепашке был дан для исполнения следующий алгоритм:

^ Повтори 5 [Вперед 10 Направо 120]

Какая фигура появится на экране?

1) незамкнутая ломаная линия

2) правильный треугольник

3) правильный пятиугольник

4) правильный шестиугольник


  1. Исполнитель Черепашка перемещается на экране компьютера, оставляя след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существуют две команды:

Вперед n (где n – целое число), вызывающая передвижение Черепашки на n шагов в направлении движения.

Направо m (где m – целое число), вызывающая изменение направления движения на m градусов по часовой стрелке.

Запись ^ Повтори k [Команда1 Команда2] означает, что последовательность команд в скобках повторится k раз.

Черепашке был дан для исполнения следующий алгоритм:

^ Повтори 6 [Вперед 5 Направо 30]

Какая фигура появится на экране?

1) незамкнутая ломаная линия

2) правильный треугольник

3) правильный пятиугольник

4) правильный шестиугольник


  1. Исполнитель Черепашка перемещается на экране компьютера, оставляя след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существуют две команды:

Вперед n (где n – целое число), вызывающая передвижение Черепашки на n шагов в направлении движения.

Направо m (где m – целое число), вызывающая изменение направления движения на m градусов по часовой стрелке.

Запись Повтори k [Команда1 Команда2 Команда3] означает, что последовательность команд в скобках повторится k раз.

Черепашке был дан для исполнения следующий алгоритм:

Повтори 3 [Направо 30 Вперед 20 Направо 30]

Какая фигура появится на экране?

1) правильный треугольник

2) квадрат

3) правильный шестиугольник

4) незамкнутая ломаная линия